summaryrefslogtreecommitdiffstats
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorMatthew Booth <mbooth@redhat.com>2012-01-25 15:10:01 +0000
committerMatthew Booth <mbooth@redhat.com>2012-01-26 11:49:12 +0000
commit8bad4d1c4765fd997511a505cdb2a860148ae16d (patch)
tree7f842d4fed405d5c8db722dfe89d60dc53dbae52 /gobject/Makefile.am
parent6568dd85f4aef705e7cf5c4301bc3b8f7119efd2 (diff)
downloadlibguestfs-8bad4d1c4765fd997511a505cdb2a860148ae16d.tar.gz
libguestfs-8bad4d1c4765fd997511a505cdb2a860148ae16d.tar.xz
libguestfs-8bad4d1c4765fd997511a505cdb2a860148ae16d.zip
gobject: Add an explicit close call
This change binds guestfs_close(). It consequently results in RConstOptString being able to throw an error.
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 5ea44883..71de7cce 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -22,7 +22,8 @@ BUILT_SOURCES = \
EXTRA_DIST = \
$(BUILT_SOURCES) \
bindtests-manual.js \
- run-bindtests
+ tests-misc.js \
+ run-tests
libname = libguestfs-gobject-1.0.la
@@ -60,7 +61,7 @@ gir_DATA = $(INTROSPECTION_GIRS)
typelibdir = $(libdir)/girepository-1.0
typelib_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
-TESTS = run-bindtests
+TESTS = run-tests
TESTS_ENVIRONMENT = GJS=$(GJS)
$(TESTS): $(typelib_DATA)