summaryrefslogtreecommitdiffstats
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2012-05-23 22:49:35 +0200
committerHilko Bengen <bengen@debian.org>2012-05-28 20:01:47 +0200
commit148e8068267bcf9ce8ff3a5062747998f960619d (patch)
treee76242f168445a5f2d6c5548b8926e8d3737d423 /gobject/Makefile.am
parentbcbb6bb760d45b3a640c5e0c9d0e0cf64c2cf0f2 (diff)
downloadlibguestfs-148e8068267bcf9ce8ff3a5062747998f960619d.tar.gz
libguestfs-148e8068267bcf9ce8ff3a5062747998f960619d.tar.xz
libguestfs-148e8068267bcf9ce8ff3a5062747998f960619d.zip
Fix out-of-tree build for GObject bindings
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index be6d58e1..f75bcf6b 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -58,7 +58,7 @@ libguestfs_gobject_1_0_la_LIBADD = -lguestfs
# in the subdirectory.
install-data-hook:
rm $(DESTDIR)$(includedir)/guestfs-gobject/guestfs-gobject.h
- install -m 0644 include/guestfs-gobject.h $(DESTDIR)$(includedir)
+ install -m 0644 $(srcdir)/include/guestfs-gobject.h $(DESTDIR)$(includedir)
-include $(INTROSPECTION_MAKEFILE)
INTROSPECTION_GIRS =
@@ -75,7 +75,7 @@ Guestfs-1.0.gir: $(libname)
Guestfs_1_0_gir_INCLUDES = GObject-2.0 Gio-2.0
Guestfs_1_0_gir_CFLAGS = $(INCLUDES) -I$(srcdir)/include
Guestfs_1_0_gir_LIBS = $(libname)
-Guestfs_1_0_gir_FILES = $(introspection_sources)
+Guestfs_1_0_gir_FILES = $(patsubst %,$(srcdir)/%,$(introspection_sources))
INTROSPECTION_GIRS += Guestfs-1.0.gir
girdir = $(datadir)/gir-1.0