summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-08-26 18:17:39 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-08-26 21:54:59 +0100
commit6146412f06c2f6f33c3ea7d571f16d4fe71dddb2 (patch)
treed9a6cbbbff64ff1371712d8856c589310b6c4c41 /fish/Makefile.am
parent0bd055316f8581f4da33b039e33d5f61cc00294c (diff)
downloadlibguestfs-6146412f06c2f6f33c3ea7d571f16d4fe71dddb2.tar.gz
libguestfs-6146412f06c2f6f33c3ea7d571f16d4fe71dddb2.tar.xz
libguestfs-6146412f06c2f6f33c3ea7d571f16d4fe71dddb2.zip
fish: Make progress bars into a mini library.
This library could now be called from other virt tools.
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index 3be14fa3..dd0625d2 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -57,8 +57,8 @@ EXTRA_DIST = \
virt-tar-in.pod \
virt-tar-out.pod
-# These source files (all related to option parsing) are shared
-# between guestfish, guestmount and some other C virt tools. Keep a
+# These source files (mostly related to option parsing) are shared
+# between guestfish, guestmount and some other virt tools. Keep a
# convenient list here just so we know which ones are shared. These
# files must not include other guestfish files.
SHARED_SOURCE_FILES = \
@@ -67,6 +67,8 @@ SHARED_SOURCE_FILES = \
keys.c \
options.h \
options.c \
+ progress.h \
+ progress.c \
virt.c
guestfish_SOURCES = \
@@ -93,10 +95,8 @@ guestfish_SOURCES = \
prep_fs.c \
prep_lv.c \
prep_boot.c \
- progress.c \
rc.c \
reopen.c \
- rmsd.h \
setenv.c \
supported.c \
tilde.c \