summaryrefslogtreecommitdiffstats
path: root/edit/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-09-23 11:12:05 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-09-23 11:37:37 +0100
commit7801621dc946fe894c960e683db3cf921ef23af6 (patch)
tree32ff8764c1d73090c9030e1270088cbad5d734d5 /edit/Makefile.am
parentd15195bad9e50f4d80e84c39100a217a260fc806 (diff)
downloadlibguestfs-7801621dc946fe894c960e683db3cf921ef23af6.tar.gz
libguestfs-7801621dc946fe894c960e683db3cf921ef23af6.tar.xz
libguestfs-7801621dc946fe894c960e683db3cf921ef23af6.zip
New tool: virt-edit
Edit any file in a guest. This was possibly previously using guestfish, but having a separate command makes it simpler. The usage is simply: virt-edit mydomain /some/file It runs $EDITOR or vi on the file, and if the user changes it, uploads the result back to the VM.
Diffstat (limited to 'edit/Makefile.am')
-rw-r--r--edit/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/edit/Makefile.am b/edit/Makefile.am
new file mode 100644
index 00000000..4fd25f0e
--- /dev/null
+++ b/edit/Makefile.am
@@ -0,0 +1,48 @@
+# libguestfs virt-edit
+# Copyright (C) 2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ run-edit-locally \
+ virt-edit.pl
+
+if HAVE_EDIT
+
+man_MANS = virt-edit.1
+
+noinst_DATA = @top_builddir@/html/virt-edit.1.html
+
+virt-edit.1: virt-edit.pl
+ $(POD2MAN) \
+ --section 1 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+@top_builddir@/html/virt-edit.1.html: virt-edit.pl
+ mkdir -p @top_builddir@/html
+ cd @top_builddir@ && pod2html \
+ --css 'pod.css' \
+ --title 'virt-edit, edit a file in a virtual machine' \
+ --htmldir html \
+ --outfile html/virt-edit.1.html \
+ edit/$<
+
+install-data-hook:
+ mkdir -p $(DESTDIR)$(bindir)
+ install -m 0755 virt-edit.pl $(DESTDIR)$(bindir)/virt-edit
+
+endif