summaryrefslogtreecommitdiffstats
path: root/df/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-10-19 10:18:46 +0100
committerRichard Jones <rjones@redhat.com>2009-10-19 10:18:46 +0100
commit945b6e0a085611b45b2ab0752a66e6e60b21666c (patch)
tree003770dd080fa3644dd2a77f3ed40592f19c03a5 /df/Makefile.am
parent854f8e0d5643e55d045f5816a520d49a057990ef (diff)
downloadlibguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.tar.gz
libguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.tar.xz
libguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.zip
Move virt tools (virt-cat, virt-edit etc) into tools/ subdirectory.
This moves the tool programs into a single directory: cat/* -> tools/virt-cat df/* -> tools/virt-df edit/* -> tools/virt-edit rescue/* -> tools/virt-rescue This in itself simplifies the build process because we only need one Makefile and one copy of 'run-locally'. 'run-*-locally' has become just 'run-locally' and takes an extra parameter which is the name of the tool, eg: run-locally cat [virt-cat params...] virt-inspector stays in its own directory, because this contains more than just a single Perl script.
Diffstat (limited to 'df/Makefile.am')
-rw-r--r--df/Makefile.am45
1 files changed, 0 insertions, 45 deletions
diff --git a/df/Makefile.am b/df/Makefile.am
deleted file mode 100644
index f333f973..00000000
--- a/df/Makefile.am
+++ /dev/null
@@ -1,45 +0,0 @@
-# libguestfs virt-df
-# Copyright (C) 2009 Red Hat Inc.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-
-EXTRA_DIST = \
- run-df-locally \
- virt-df
-
-if HAVE_DF
-
-bin_SCRIPTS = virt-df
-man_MANS = virt-df.1
-
-noinst_DATA = $(top_builddir)/html/virt-df.1.html
-
-virt-df.1: virt-df
- $(POD2MAN) \
- --section 1 \
- -c "Virtualization Support" \
- --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
- $< > $@-t && mv $@-t $@
-
-$(top_builddir)/html/virt-df.1.html: virt-df
- mkdir -p $(top_builddir)/html
- cd $(top_builddir) && pod2html \
- --css 'pod.css' \
- --title 'virt-df, display free space on virtual filesystems' \
- --htmldir html \
- --outfile html/virt-df.1.html \
- df/$<
-
-endif