summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-11-22 14:49:54 +0000
committerRichard W.M. Jones <rjones@redhat.com>2012-11-22 16:45:32 +0000
commitfae8d7cafb66e0da697cde71f7e9444165c76ff7 (patch)
tree9ef86b17795fab79a3e4d56ececd6de0817168c7 /configure.ac
parent218b39acae324955b089dcfc191b0270b6bafb62 (diff)
downloadlibguestfs-fae8d7cafb66e0da697cde71f7e9444165c76ff7.tar.gz
libguestfs-fae8d7cafb66e0da697cde71f7e9444165c76ff7.tar.xz
libguestfs-fae8d7cafb66e0da697cde71f7e9444165c76ff7.zip
New APIs: Implement Linux filesystem capabilities.
This adds the following new APIs: - cap_get_file - cap_set_file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f930f5b..c79f3a7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -701,6 +701,15 @@ AC_CHECK_LIB([acl],[acl_from_text],
],
[AC_MSG_WARN([POSIX acl library not found])])
+dnl Linux capabilities library (libcap) (highly recommended)
+AC_CHECK_LIB([cap],[cap_from_text],
+ [AC_CHECK_HEADER([sys/capability.h],
+ [AC_SUBST([CAP_LIBS], [-lcap])
+ AC_DEFINE([HAVE_CAP], [1], [Define to 1 if the Linux capabilities library (libcap) is available.])
+ ], [])
+ ],
+ [AC_MSG_WARN([Linux capabilities library (libcap) not found])])
+
dnl libvirt (highly recommended)
AC_ARG_WITH([libvirt],
[AS_HELP_STRING([--without-libvirt],