summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWulf C. Krueger <philantrop@exherbo.org>2012-08-27 20:28:48 +0200
committerRichard W.M. Jones <rjones@redhat.com>2012-08-28 10:20:47 -0400
commitcab48ce73cb19b1aa8784e6c6a3cb8f47b0cbc0e (patch)
tree0036a7cb724f1b952e9edb5ce2d47bfdade7fc90 /configure.ac
parent81709b5b70f0a3388ba7df80072756855bceaa81 (diff)
downloadlibguestfs-cab48ce73cb19b1aa8784e6c6a3cb8f47b0cbc0e.tar.gz
libguestfs-cab48ce73cb19b1aa8784e6c6a3cb8f47b0cbc0e.tar.xz
libguestfs-cab48ce73cb19b1aa8784e6c6a3cb8f47b0cbc0e.zip
Fix disabling the Perl bindings.
--disable-perl isn't currently respected because $PERL correctly points to the perl executable and $missing_perl_modules doesn't prevent the perl parts to be installed either. Thus, a check for $enable_perl is needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index eb37e0c9..6d2ef4d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -908,7 +908,7 @@ AS_IF([test "x$enable_perl" != "xno"],[
fi
])
AM_CONDITIONAL([HAVE_PERL],
- [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
+ [test "x$enable_perl" != "xno" && test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
dnl Check for Python (optional, for Python bindings).
PYTHON_PREFIX=