summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Koltsov <kolmax94@gmail.com>2010-11-08 15:08:01 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-08 15:08:01 +0000
commitb0a48fa4504f85baa484987f54d8f99703e3ed3b (patch)
treed8567fdf0c44b477524d5c5b1208b8974671f6d4 /configure.ac
parent8e4a4d3d88b814504c6f2abbf6bf3dab789021b1 (diff)
downloadlibguestfs-b0a48fa4504f85baa484987f54d8f99703e3ed3b.tar.gz
libguestfs-b0a48fa4504f85baa484987f54d8f99703e3ed3b.tar.xz
libguestfs-b0a48fa4504f85baa484987f54d8f99703e3ed3b.zip
build: Add ./configure --disable-php option.
This disables the PHP language bindings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index db2eb029..9cfb0008 100644
--- a/configure.ac
+++ b/configure.ac
@@ -776,6 +776,20 @@ AS_IF([test "x$enable_haskell" != "xno"],
AM_CONDITIONAL([HAVE_HASKELL],
[test "x$GHC" != "xno"])
+dnl PHP
+PHP=no
+AC_ARG_ENABLE([php],
+ AS_HELP_STRING([--disable-php], [Disable PHP language bindings]),
+ [],
+ [enable_php=yes])
+AS_IF([test "x$enable_php" != "xno"],
+ [
+ PHP=
+ AC_CHECK_PROG([PHP],[php],[php],[no])
+ AC_CHECK_PROG([PHPIZE],[phpize],[phpize],[no])
+ ])
+AM_CONDITIONAL([HAVE_PHP], [test "x$PHP" != "xno" && test "x$PHPIZE" != "xno"])
+
dnl Check for Perl modules needed by virt-df, inspector, etc.
AS_IF([test "x$PERL" != "xno"],
[
@@ -803,11 +817,6 @@ dnl po4a for translating man pages and POD files (optional).
AC_CHECK_PROG([PO4A],[po4a],[po4a],[no])
AM_CONDITIONAL([HAVE_PO4A], [test "x$PO4A" != "xno"])
-dnl PHP
-AC_CHECK_PROG([PHP],[php],[php],[no])
-AC_CHECK_PROG([PHPIZE],[phpize],[phpize],[no])
-AM_CONDITIONAL([HAVE_PHP], [test "x$PHP" != "xno" && test "x$PHPIZE" != "xno"])
-
dnl Library versioning.
MAX_PROC_NR=`cat $srcdir/src/MAX_PROC_NR`
AC_SUBST(MAX_PROC_NR)