summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-03-04 14:41:37 +0000
committerRichard W.M. Jones <rjones@redhat.com>2012-03-04 14:41:37 +0000
commit705971b509e1c60419444f228825533080c4ae34 (patch)
treef8cf8010084a274eed80e7b2049d7b8a1dbc4105 /configure.ac
parent49611f121fa10d1497e46ab9aa6a7448cb89cd86 (diff)
downloadlibguestfs-705971b509e1c60419444f228825533080c4ae34.tar.gz
libguestfs-705971b509e1c60419444f228825533080c4ae34.tar.xz
libguestfs-705971b509e1c60419444f228825533080c4ae34.zip
Test header file under C++.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1eb94922..0a2e6629 100644
--- a/configure.ac
+++ b/configure.ac
@@ -686,6 +686,13 @@ AS_IF([test "x$enable_fuse" != "xno"],
AC_MSG_WARN([FUSE library and headers are missing, so optional FUSE module won't be built])])])
AM_CONDITIONAL([HAVE_FUSE],[test "x$enable_fuse" != "xno"])
+dnl Check for C++ (optional, we just use this to test the header works).
+AC_PROG_CXX
+
+dnl The C++ compiler test is pretty useless because even if it fails
+dnl it sets CXX=g++. So test the compiler actually works.
+AM_CONDITIONAL([HAVE_CXX], [$CXX --version])
+
dnl Check for OCaml (optional, for OCaml bindings).
OCAMLC=no
OCAMLFIND=no