summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-01-04 15:39:49 +0000
committerRichard Jones <rjones@redhat.com>2010-01-04 16:23:36 +0000
commit5e180db9eefcd6b459b805c2215ba4d174e4eb83 (patch)
tree343a3858e27041771d15da3dc9e63a2c31ab1e0e /configure.ac
parentdb430348cae9f99549a4f7e155a162e71fb9900d (diff)
downloadlibguestfs-5e180db9eefcd6b459b805c2215ba4d174e4eb83.tar.gz
libguestfs-5e180db9eefcd6b459b805c2215ba4d174e4eb83.tar.xz
libguestfs-5e180db9eefcd6b459b805c2215ba4d174e4eb83.zip
Use linker script to control visibility of symbols.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a781c75..d7ad7c7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,6 +116,12 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
AM_PROG_CC_C_O
+dnl Work out how to specify the linker script to the linker.
+VERSION_SCRIPT_FLAGS=-Wl,--version-script=
+`/usr/bin/ld --help 2>&1 | grep -- --version-script >/dev/null` || \
+ VERSION_SCRIPT_FLAGS="-Wl,-M -Wl,"
+AC_SUBST(VERSION_SCRIPT_FLAGS)
+
dnl Check support for 64 bit file offsets.
AC_SYS_LARGEFILE