summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-03-07 15:07:37 +0000
committerRichard W.M. Jones <rjones@redhat.com>2012-03-07 18:36:46 +0000
commit2c9c0525ebda105f37e6a6eea2307db4cb2f0a73 (patch)
treea9b64646eefc0eee068d0ba01f04f3d284871587 /configure.ac
parentb9061ddf2d337fcc42cfeae0ac8ec4e329a1a421 (diff)
downloadlibguestfs-2c9c0525ebda105f37e6a6eea2307db4cb2f0a73.tar.gz
libguestfs-2c9c0525ebda105f37e6a6eea2307db4cb2f0a73.tar.xz
libguestfs-2c9c0525ebda105f37e6a6eea2307db4cb2f0a73.zip
build: Make netpbm and icoutils into proper optional dependencies.
Netpbm and icoutils (wrestool) have always been dependencies. Since they are not always present, make these into optional dependencies (which they were, sort of, before). Also document these dependencies in the README file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6ff0977d..fc32a2a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -466,6 +466,30 @@ if test "x$DB_LOAD" != "xno"; then
AC_DEFINE_UNQUOTED([DB_LOAD],["$DB_LOAD"],[Name of db_load program.])
fi
+dnl Check for netpbm programs (optional).
+AC_CHECK_PROGS([PBMTEXT],[pbmtext],[no])
+AC_CHECK_PROGS([PNMTOPNG],[pnmtopng],[no])
+AC_CHECK_PROGS([BMPTOPNM],[bmptopnm],[no])
+AC_CHECK_PROGS([PAMCUT],[pamcut],[no])
+if test "x$PBMTEXT" != "xno"; then
+ AC_DEFINE_UNQUOTED([PBMTEXT],["$PBMTEXT"],[Name of pbmtext program.])
+fi
+if test "x$PNMTOPNG" != "xno"; then
+ AC_DEFINE_UNQUOTED([PNMTOPNG],["$PNMTOPNG"],[Name of pnmtopng program.])
+fi
+if test "x$BMPTOPNM" != "xno"; then
+ AC_DEFINE_UNQUOTED([BMPTOPNM],["$BMPTOPNM"],[Name of bmptopnm program.])
+fi
+if test "x$PAMCUT" != "xno"; then
+ AC_DEFINE_UNQUOTED([PAMCUT],["$PAMCUT"],[Name of pamcut program.])
+fi
+
+dnl Check for icoutils (optional).
+AC_CHECK_PROGS([WRESTOOL],[wrestool],[no])
+if test "x$WRESTOOL" != "xno"; then
+ AC_DEFINE_UNQUOTED([WRESTOOL],["$WRESTOOL"],[Name of wrestool program.])
+fi
+
dnl Check for QEMU for running binaries on this $host_cpu, fall
dnl back to basic 'qemu'. Allow the user to override it.
default_qemu="qemu-kvm kvm qemu-system-$host_cpu qemu"