summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-09-11 08:11:43 +0100
committerRichard Jones <rjones@redhat.com>2010-09-11 08:11:43 +0100
commit264629b9f0ace1062b453b2d0ae55e48385189d3 (patch)
tree122c23c53683f0b71c2cb00c7fe6d1c7d2ecc4c4 /configure.ac
parent431503d007b22bf10226843cca84628544fadca9 (diff)
downloadlibguestfs-264629b9f0ace1062b453b2d0ae55e48385189d3.tar.gz
libguestfs-264629b9f0ace1062b453b2d0ae55e48385189d3.tar.xz
libguestfs-264629b9f0ace1062b453b2d0ae55e48385189d3.zip
syntax: Replace -a and -o with && and || for portability.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 13 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index f6bb5cd4..96e6f532 100644
--- a/configure.ac
+++ b/configure.ac
@@ -265,7 +265,7 @@ if test "x$vmchannel_test" != "xno"; then
vmchannel_net_user=no
fi
- if test "x$vmchannel_net_user" = "xno" -a "x$vmchannel_guestfwd" = "xno"; then
+ if test "x$vmchannel_net_user" = "xno" && test "x$vmchannel_guestfwd" = "xno"; then
AC_MSG_FAILURE(
[I did not find user mode network or vmchannel support in
$QEMU.
@@ -352,8 +352,8 @@ if test "x$enable_appliance" = "xyes"; then
AC_MSG_RESULT([$fakechroot_version])
fakechroot_major=`echo "$fakechroot_version" | awk -F. '{print $1}'`
fakechroot_minor=`echo "$fakechroot_version" | awk -F. '{print $2}'`
- if test "$fakechroot_major" -lt 2 -o \
- \( "$fakechroot_major" -eq 2 -a "$fakechroot_minor" -lt 9 \); then
+ if test "$fakechroot_major" -lt 2 || \
+ ( test "$fakechroot_major" -eq 2 && test "$fakechroot_minor" -lt 9 ); then
AC_MSG_ERROR([fakechroot version must be >= 2.9])
fi
fi
@@ -499,11 +499,11 @@ AM_CONDITIONAL([HAVE_FUSE],[test "x$HAVE_FUSE" = "xyes"])
dnl Check for OCaml (optional, for OCaml bindings).
AC_PROG_OCAML
AC_PROG_FINDLIB
-AM_CONDITIONAL([HAVE_OCAML],[test "x$OCAMLC" != "xno" -a "x$OCAMLFIND" != "xno"])
+AM_CONDITIONAL([HAVE_OCAML],[test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"])
dnl Optional xml-light for running the generator.
OCAML_PKG_xml_light=no
-if test "x$OCAMLC" != "xno" -a "x$OCAMLFIND" != "xno"; then
+if test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"; then
AC_CHECK_OCAML_PKG([xml-light])
fi
AM_CONDITIONAL([HAVE_XML_LIGHT],[test "x$OCAML_PKG_xml_light" != "xno"])
@@ -539,7 +539,7 @@ if test "x$missing_perl_modules" = "xyes"; then
fi
AM_CONDITIONAL([HAVE_PERL],
- [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
+ [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
dnl Check for Python (optional, for Python bindings).
AC_CHECK_PROG([PYTHON],[python],[python],[no])
@@ -593,14 +593,14 @@ AC_SUBST(PYTHON_INCLUDEDIR)
AC_SUBST(PYTHON_SITE_PACKAGES)
AM_CONDITIONAL([HAVE_PYTHON],
- [test "x$PYTHON_INCLUDEDIR" != "x" -a "x$PYTHON_SITE_PACKAGES" != "x"])
+ [test "x$PYTHON_INCLUDEDIR" != "x" && test "x$PYTHON_SITE_PACKAGES" != "x"])
dnl Check for Ruby and rake (optional, for Ruby bindings).
AC_CHECK_LIB([ruby],[ruby_init],[HAVE_LIBRUBY=1],[HAVE_LIBRUBY=0])
AC_CHECK_PROG([RAKE],[rake],[rake],[no])
AM_CONDITIONAL([HAVE_RUBY],
- [test "x$RAKE" != "xno" -a -n "$HAVE_LIBRUBY"])
+ [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY"])
dnl Check for Java.
AC_ARG_WITH(java_home,
@@ -610,7 +610,7 @@ AC_ARG_WITH(java_home,
[with_java_home=check])
if test "x$with_java_home" != "xno"; then
- if test "x$with_java_home" != "xyes" -a "x$with_java_home" != "xcheck"
+ if test "x$with_java_home" != "xyes" && test "x$with_java_home" != "xcheck"
then
# Reject unsafe characters in $JAVA_HOME
jh_lf='
@@ -632,7 +632,7 @@ if test "x$with_java_home" != "xno"; then
/usr/lib/jvm/java \
/usr/lib/jvm/java-6-openjdk
do
- if test -d $d -a -f $d/bin/java; then
+ if test -d $d && test -f $d/bin/java; then
JAVA_HOME=$d
break
fi
@@ -764,9 +764,9 @@ if test "x$missing_perl_modules" = "xyes"; then
fi
AM_CONDITIONAL([HAVE_INSPECTOR],
- [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
+ [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
AM_CONDITIONAL([HAVE_TOOLS],
- [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
+ [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
dnl po4a for translating man pages and POD files (optional).
AC_CHECK_PROG([PO4A],[po4a],[po4a],[no])
@@ -775,7 +775,7 @@ AM_CONDITIONAL([HAVE_PO4A], [test "x$PO4A" != "xno"])
dnl PHP
AC_CHECK_PROG([PHP],[php],[php],[no])
AC_CHECK_PROG([PHPIZE],[phpize],[phpize],[no])
-AM_CONDITIONAL([HAVE_PHP], [test "x$PHP" != "xno" -a "x$PHPIZE" != "xno"])
+AM_CONDITIONAL([HAVE_PHP], [test "x$PHP" != "xno" && test "x$PHPIZE" != "xno"])
dnl Library versioning.
MAX_PROC_NR=`cat $srcdir/src/MAX_PROC_NR`