summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-12-19 10:56:06 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-19 10:57:06 +0000
commitda24e7aab06361b8d9bb5b5c8417611501e94684 (patch)
treee4041b7a905f825e7d5009071567be75d52e10b1 /appliance/Makefile.am
parent9556903888eed268895a8454491d56302985f7e1 (diff)
downloadlibguestfs-da24e7aab06361b8d9bb5b5c8417611501e94684.tar.gz
libguestfs-da24e7aab06361b8d9bb5b5c8417611501e94684.tar.xz
libguestfs-da24e7aab06361b8d9bb5b5c8417611501e94684.zip
appliance: Don't hard-code febootstrap --exclude parameters.
Create a separate file 'excludelist.in' that contains these regular expressions, and process it the same way as packagelist.in.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index f1c23279..503160ea 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -19,6 +19,7 @@ include $(top_srcdir)/subdir-rules.mk
EXTRA_DIST = \
packagelist.in \
+ excludelist.in \
init \
make.sh.in
@@ -46,8 +47,13 @@ packagelist: packagelist.in
grep -v '^[[:space:]]*$$' | grep -v '^#' > $@-t
mv $@-t $@
+excludelist: excludelist.in
+ cpp -undef -D$(DISTRO)=1 < $< | \
+ grep -v '^[[:space:]]*$$' | grep -v '^#' > $@-t
+ mv $@-t $@
+
supermin.d/base.img supermin.d/hostfiles: stamp-supermin
-stamp-supermin: make.sh packagelist
+stamp-supermin: make.sh packagelist excludelist
mkdir -p supermin.d
rm -f $@ supermin.d/base.img supermin.d/hostfiles
./make.sh
@@ -70,7 +76,7 @@ supermin.d/init.img: init
# Make clean.
-CLEANFILES = packagelist
+CLEANFILES = packagelist excludelist
clean-local:
rm -rf supermin.d