summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorMatthew Booth <mbooth@redhat.com>2010-09-21 10:50:41 +0100
committerRichard W.M. Jones <rjones@redhat.com>2010-09-21 10:56:47 +0100
commitd1c2287fe4636db9a54888e71fb150984f00b0e4 (patch)
tree13aafc2f50020346db6a6ac4ef7d6315f5253ef0 /appliance/Makefile.am
parentff4ae8633e0ca7c1e679870600830ee4d9f1cd71 (diff)
downloadlibguestfs-d1c2287fe4636db9a54888e71fb150984f00b0e4.tar.gz
libguestfs-d1c2287fe4636db9a54888e71fb150984f00b0e4.tar.xz
libguestfs-d1c2287fe4636db9a54888e71fb150984f00b0e4.zip
Fix appliance build dependency problem
The appliance was being completely rebuilt every time guestfsd was updated. This was because make.sh depended on guestfsd, which it had to do because it called update.sh to install guestfsd. This fix removes the call to update.sh in make.sh, and therefore the dependency on guestfsd. The Makefile already includes a rule to run update.sh when guestfsd is updated, so this was unnecessary.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index bbf3c243..172f0cf7 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -53,7 +53,7 @@ VMLINUZ = vmlinuz.$(REPO).$(host_cpu)
# This is for building the normal appliance:
$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist $(top_builddir)/daemon/guestfsd
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
if ! bash make.sh; then rm -f $@; exit 1; fi