summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-07-03 10:47:10 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-07-03 10:48:55 +0100
commita67c46b4b2ff5a2c4305e39d1bb105b658ca5f89 (patch)
tree947bc289c69a3cddbd9c619ecb5e180cc753339a /appliance/Makefile.am
parent447dae7df43e8a98da59d94f1aef9895e087aa13 (diff)
downloadlibguestfs-a67c46b4b2ff5a2c4305e39d1bb105b658ca5f89.tar.gz
libguestfs-a67c46b4b2ff5a2c4305e39d1bb105b658ca5f89.tar.xz
libguestfs-a67c46b4b2ff5a2c4305e39d1bb105b658ca5f89.zip
Add Debian appliance directory to the distfile.
'make dist' won't copy symlinks into the output file, so we have to add a rule to the Makefile to copy these. (Issue reported by Guido Gunther).
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index 03b2a7b4..9de11cde 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -21,7 +21,11 @@ EXTRA_DIST = \
kmod.whitelist \
kmod.whitelist.in \
packagelist.in \
- init
+ init \
+ debian/modules/install_kernel \
+ debian/modules/y0_install-guestfsd \
+ debian/modules/z99_final-cleanups \
+ debian/debirf.conf.in
# Build the root filesystem (appliance).
# Currently this is arch-dependent, so it seems like putting it in
@@ -92,6 +96,23 @@ $(SUPERMINIMG): supermin.incfiles supermin-make.sh
endif
+# Extra symlinks needed by the Debian appliance.
+debirf_symlinks = \
+ a0_motd \
+ a0_prep-root \
+ network \
+ root-bashrc \
+ serial-terminal \
+ z0_remove-aptitude \
+ z0_remove-locales \
+ z1_clean-root
+noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
+$(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
+stamp-debirf-modules:
+ for f in $(debirf_symlinks); do \
+ ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
+ done
+
#----------------------------------------------------------------------
# Extra rules for testing the appliance.