summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-12-04 21:14:17 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-05 11:23:23 +0000
commit6d75ce8e6ca1f3f0a946ee4e214f6d2bff07adc4 (patch)
treeeabf83eb465fa7f7ff7347ee26547a18675b476d /appliance/Makefile.am
parent078fbee4e73036783aefef9401735f8b80e81bb2 (diff)
downloadlibguestfs-6d75ce8e6ca1f3f0a946ee4e214f6d2bff07adc4.tar.gz
libguestfs-6d75ce8e6ca1f3f0a946ee4e214f6d2bff07adc4.tar.xz
libguestfs-6d75ce8e6ca1f3f0a946ee4e214f6d2bff07adc4.zip
appliance: Change to using febootstrap 3.x supermin appliance.
This removes all support for building the ordinary / old style appliance using febootstrap 2.x, debootstrap, debirf, fakeroot and fakechroot. Instead this uses febootstrap 3.x to build the supermin appliance in a simpler cross-distro manner.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am88
1 files changed, 13 insertions, 75 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index dec1c156..cd4952a1 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -18,46 +18,19 @@
include $(top_srcdir)/subdir-rules.mk
EXTRA_DIST = \
- kmod.whitelist.in \
packagelist.in \
init \
- debian/modules/y0_install-guestfsd \
- debian/modules/z99_final-cleanups \
- debian/debirf.conf.in \
make.sh.in
-# Build the root filesystem (appliance).
-# Currently this is arch-dependent, so it seems like putting it in
-# $(libdir) is best. When we build cross-architecture filesystems we
-# should probably move them to $(datadir).
fsdir = $(libdir)/guestfs
superminfsdir = $(libdir)/guestfs/supermin.d
-# These are the resulting output files from the whole process:
-# VMLINUZ kernel for the full appliance
-# INITRAMFSIMG initramfs (ie. root fs) for the full appliance
-# For details of the supermin appliance, read the README file.
-fs_DATA = $(INITRAMFSIMG) $(VMLINUZ)
-if SUPERMIN
-fs_DATA += kmod.whitelist
+fs_DATA =
superminfs_DATA = \
supermin.d/base.img \
supermin.d/daemon.img \
supermin.d/init.img \
supermin.d/hostfiles
-endif
-
-# Don't change these names - they must be the same as in '*.sh' scripts.
-INITRAMFSIMG = initramfs.$(host_cpu).img
-VMLINUZ = vmlinuz.$(host_cpu)
-
-# This is for building the normal appliance:
-$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
-
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
- mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
- mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
- if ! bash make.sh; then rm -f $@; exit 1; fi
# This used to be a configure-generated file (as is update.sh still).
# However config.status always touches the destination file, which
@@ -68,70 +41,35 @@ make.sh: make.sh.in
chmod +x $@-t
mv $@-t $@
-$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh
- rm -f $@
- bash update.sh
- touch $@
-
-kmod.whitelist: kmod.whitelist.in
- grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
-
packagelist: packagelist.in
- cpp -undef -D$(DIST)=1 < $< | \
+ cpp -undef -D$(DISTRO)=1 < $< | \
grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
-# This is for building the supermin appliance. It has to be enabled
-# specifically with './configure --enable-supermin'. You really need
-# to read the README file.
-
-if SUPERMIN
-
supermin.d/base.img supermin.d/hostfiles: stamp-supermin
-stamp-supermin: $(INITRAMFSIMG)
+stamp-supermin: make.sh packagelist
mkdir -p supermin.d
rm -f $@ supermin.d/base.img supermin.d/hostfiles
- febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
- if grep -q /usr/share/augeas/lenses supermin.d/hostfiles; then \
- echo "./usr/share/augeas/lenses/*.aug" >> supermin.d/hostfiles; \
- fi
+ ./make.sh
touch $@
-supermin.d/daemon.img: $(INITRAMFSIMG)
+supermin.d/daemon.img: ../daemon/guestfsd
mkdir -p supermin.d
rm -f $@ $@-t
- (cd $(top_builddir)/initramfs && \
- echo -e "sbin\nsbin/guestfsd" | cpio --quiet -o -H newc ) > $@-t
+ mkdir sbin
+ cd sbin && ln ../../daemon/guestfsd
+ echo -e "sbin\nsbin/guestfsd" | cpio --quiet -o -H newc > $@-t
+ rm -r sbin
mv $@-t $@
-supermin.d/init.img: $(INITRAMFSIMG)
+supermin.d/init.img: init
mkdir -p supermin.d
rm -f $@ $@-t
- (cd $(top_builddir)/initramfs && \
- echo -e "init\n" | cpio --quiet -o -H newc ) > $@-t
+ echo "init" | cpio --quiet -o -H newc > $@-t
mv $@-t $@
-endif
-
-# Extra symlinks needed by the Debian appliance.
-debirf_symlinks = \
- a0_prep-root \
- install-kernel \
- z0_remove-aptitude \
- z0_remove-locales \
- z1_clean-root
-noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
-$(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
-stamp-debirf-modules:
- mkdir -p debian/modules
- for f in $(debirf_symlinks); do \
- ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
- done
- touch $@
-
# Make clean.
-CLEANFILES = packagelist kmod.whitelist
+CLEANFILES = packagelist
clean-local:
- rm -f supermin.d/*
- rm -rf $(top_builddir)/initramfs
+ rm -rf supermin.d