summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-06-19 14:26:44 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-06-19 14:26:44 +0100
commit677b280411cd3596051f288eecb73b5d8ae23caa (patch)
tree4fe73a993767fb29b54a069fb519931f41289051 /appliance/Makefile.am
parente395d7db8fd3fe3d1b121258fe2f401d6b3e64c8 (diff)
downloadlibguestfs-677b280411cd3596051f288eecb73b5d8ae23caa.tar.gz
libguestfs-677b280411cd3596051f288eecb73b5d8ae23caa.tar.xz
libguestfs-677b280411cd3596051f288eecb73b5d8ae23caa.zip
Move distro package list to a separate packagelist.in file.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index 883bda56..4f5eeee0 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -19,7 +19,8 @@ EXTRA_DIST = \
make.sh update.sh supermin-split.sh supermin-make.sh \
libguestfs-supermin-helper \
kmod.whitelist \
- kmod.whitelist.in
+ kmod.whitelist.in \
+ packagelist.in
# Build the root filesystem (appliance).
# Currently this is arch-dependent, so it seems like putting it in
@@ -52,7 +53,7 @@ endif
# This is for building the normal appliance:
$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
-mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
-mv $(VMLINUZ) $(VMLINUZ).bak
if ! bash make.sh; then rm -f $@; exit 1; fi
@@ -65,6 +66,10 @@ $(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/g
kmod.whitelist: kmod.whitelist.in
grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
+packagelist: packagelist.in
+ cpp -undef -DREDHAT=1 < $< | \
+ grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
+
# This is for building the supermin appliance. It has to be enabled
# specifically with './configure --enable-supermin'. You really need
# to read the README file.