summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-07-31 07:40:57 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-07-31 10:18:40 +0100
commit641f6ae3bf14940d9057860fb022c2946c1daf1c (patch)
tree530026d46bf7ea4cbcebfbe0c65e8102bb08c44e /appliance/Makefile.am
parentbbe5877b6c86ace6f27c6f95c559a61888693923 (diff)
downloadlibguestfs-641f6ae3bf14940d9057860fb022c2946c1daf1c.tar.gz
libguestfs-641f6ae3bf14940d9057860fb022c2946c1daf1c.tar.xz
libguestfs-641f6ae3bf14940d9057860fb022c2946c1daf1c.zip
Ignore failure of 'mv' commands in appliance Makefile.
A lot of people report these as 'errors' when they are not. Hide the error messages.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index 6c8a972e..8391b8b3 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -57,8 +57,8 @@ endif
$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
- -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
- -mv $(VMLINUZ) $(VMLINUZ).bak
+ mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
+ mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
if ! bash make.sh; then rm -f $@; exit 1; fi
$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh