summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-05-14 15:15:47 +0100
committerRichard Jones <rjones@redhat.com>2010-05-14 15:43:51 +0100
commit40d270b0113f1e30319909b2d51adb5a57079cd1 (patch)
treeb6c98c0c21de433133f43ed5f19e9d53662ebc82 /appliance/Makefile.am
parent2357adc79aaf6e0b1a4b9945e186a80226330538 (diff)
downloadlibguestfs-40d270b0113f1e30319909b2d51adb5a57079cd1.tar.gz
libguestfs-40d270b0113f1e30319909b2d51adb5a57079cd1.tar.xz
libguestfs-40d270b0113f1e30319909b2d51adb5a57079cd1.zip
Ensure ordinary appliance is updated before trying to build supermin appliance.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index 157c8758..72dfc71a 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -87,13 +87,13 @@ packagelist: packagelist.in
if SUPERMIN
supermin.d/base.img supermin.d/hostfiles: stamp-supermin
-stamp-supermin: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/initramfs/init
+stamp-supermin: $(INITRAMFSIMG)
mkdir -p supermin.d
rm -f $@ supermin.d/base.img supermin.d/hostfiles
febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
touch $@
-supermin.d/daemon.img: $(top_builddir)/initramfs/sbin/guestfsd
+supermin.d/daemon.img: $(INITRAMFSIMG)
mkdir -p supermin.d
rm -f $@ $@-t
(cd $(top_builddir)/initramfs && \