summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorMatthew Booth <mbooth@redhat.com>2009-07-03 11:52:50 +0100
committerMatthew Booth <mbooth@redhat.com>2009-07-03 16:16:51 +0100
commit349814e9d912c4f372b8fbdfb10b03749911021f (patch)
tree7168b6ee4dadd363a28a73e2a5ff26799395d75c /appliance/Makefile.am
parent5f9cb51f11879ece8b921d833850505d7e57d339 (diff)
downloadlibguestfs-349814e9d912c4f372b8fbdfb10b03749911021f.tar.gz
libguestfs-349814e9d912c4f372b8fbdfb10b03749911021f.tar.xz
libguestfs-349814e9d912c4f372b8fbdfb10b03749911021f.zip
Make it possible to build in a separate directory
This patch allows you to do: mkdir build cd build ../configure ... make This will output all generated files to the build directory. Given that autogen automatically runs configure, you can also do: BUILDDIR=./build ./autogen.sh which will do the right thing. Also: * Fix a dependency bug which means that guestfs_protocol.h isn't automatically rebuilt. * Re-running autogen.sh with no arguments won't blow away your previous configure arguments.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index e2b0b315..7abee80d 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -105,6 +105,7 @@ debirf_symlinks = \
noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
$(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
stamp-debirf-modules:
+ mkdir -p debian/modules
for f in $(debirf_symlinks); do \
ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
done