summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorMatthew Booth <mbooth@redhat.com>2009-11-20 18:43:20 +0000
committerRichard Jones <rjones@redhat.com>2009-11-21 21:13:36 +0000
commit1b60344e672e4fc233d7fe6b8ecfcda46a40f4d5 (patch)
tree71f4f38836d78480d02a81e6f6e7c6dcc97dfcdd /appliance/Makefile.am
parent1befbee8b8c00026a2f98ab7bc1ed4ca67083042 (diff)
downloadlibguestfs-1b60344e672e4fc233d7fe6b8ecfcda46a40f4d5.tar.gz
libguestfs-1b60344e672e4fc233d7fe6b8ecfcda46a40f4d5.tar.xz
libguestfs-1b60344e672e4fc233d7fe6b8ecfcda46a40f4d5.zip
build: Ensure building appliance depends on guestfsd
Previously, only the update.sh rule checked the daemon had been built. update.sh is called directly from within make.sh, so in that path the dependency was never checked. This adds the daemon dependency explicitly to the rebuild-from-scratch path.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index bf1183da..abb50864 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -59,7 +59,7 @@ endif
# This is for building the normal appliance:
$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist $(top_builddir)/daemon/guestfsd
mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
if ! bash make.sh; then rm -f $@; exit 1; fi