summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-02-15 15:33:13 +0000
committerRichard Jones <rjones@redhat.com>2010-02-15 15:33:13 +0000
commited83d770252dda356bc9f8ad19149ada5e8708a5 (patch)
treeea330abbfee9923dd547f368c5958da05373a94c /Makefile.am
parent2109327021f4d464e2693e507fa92f1497ba0792 (diff)
downloadlibguestfs-ed83d770252dda356bc9f8ad19149ada5e8708a5.tar.gz
libguestfs-ed83d770252dda356bc9f8ad19149ada5e8708a5.tar.xz
libguestfs-ed83d770252dda356bc9f8ad19149ada5e8708a5.zip
Add 'make quickcheck' rule to run a quick check.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b2fa854..2c7574a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,3 +193,12 @@ CLEANFILES = $(fs_DATA) \
clean-local:
rm -rf initramfs
+
+# If you don't want to run all of the tests ('make check') then this
+# will just run libguestfs-test-tool for a quick check. Note this
+# is NOT a substitute for proper testing!
+
+quickcheck:
+ LIBGUESTFS_PATH=appliance \
+ test-tool/libguestfs-test-tool \
+ --helper test-tool/libguestfs-test-tool-helper