summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-11-24 14:08:09 +0000
committerRichard W.M. Jones <rjones@redhat.com>2011-11-24 15:51:16 +0000
commitc55bad93fbde03a3daa6058913f02098c45e55f5 (patch)
tree9fd81b3fdc5f2d55e9a84da0a0d54c337410956c /Makefile.am
parentdd76ce2b4c93dd10d8eca9ab7c77bc831f103d03 (diff)
downloadlibguestfs-c55bad93fbde03a3daa6058913f02098c45e55f5.tar.gz
libguestfs-c55bad93fbde03a3daa6058913f02098c45e55f5.tar.xz
libguestfs-c55bad93fbde03a3daa6058913f02098c45e55f5.zip
Add 'make extra-tests' rule and run extra tests.
These tests are optional, and require a special environment and tools to run.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8394ac41..5c900045 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,7 @@ SUBDIRS += appliance
endif
# Tests and the test-tool.
-SUBDIRS += gnulib/tests capitests caution regressions test-tool
+SUBDIRS += gnulib/tests capitests caution regressions extratests test-tool
# Guestfish.
SUBDIRS += fish
@@ -250,6 +250,11 @@ CLEANFILES = \
quickcheck:
./run test-tool/libguestfs-test-tool $(QUICKCHECK_TEST_TOOL_ARGS)
+# Run extra-tests in extratests/ subdirectory.
+
+extra-tests:
+ make -C extratests $@
+
# Make binary distribution.
BINTMPDIR = /tmp/libguestfs-bin