summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-07 13:08:50 +0100
committerRichard Jones <rjones@redhat.com>2009-04-07 13:08:50 +0100
commitacf9000252da7f4f3fde693ecc03461007cf0bf9 (patch)
treebe2a75846b3b28aa781f47f2ab9419fe833f05ee /Makefile.am
parentdfb90f793a40d38da47ee1b604ed0a73a05281d0 (diff)
downloadlibguestfs-acf9000252da7f4f3fde693ecc03461007cf0bf9.tar.gz
libguestfs-acf9000252da7f4f3fde693ecc03461007cf0bf9.tar.xz
libguestfs-acf9000252da7f4f3fde693ecc03461007cf0bf9.zip
Added framework for the language bindings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 39cf86cf..d34b9429 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,17 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src daemon fish examples
+SUBDIRS = src daemon fish examples images
+
+if HAVE_OCAML
+SUBDIRS += ocaml
+endif
+if HAVE_PERL
+SUBDIRS += perl
+endif
+if HAVE_PYTHON
+SUBDIRS += python
+endif
EXTRA_DIST = \
make-initramfs.sh update-initramfs.sh \