summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-04-25 16:35:12 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-04-25 17:32:30 +0100
commit87ea7a04094d5ed40f3f047ff2b7a613d4d530d4 (patch)
tree458b3713c313d124c37b8de11e45d0b081f3fde6 /Makefile.am
parent3cc9703f901e85a589692b9d0bf5ef7cbf72ed73 (diff)
downloadlibguestfs-87ea7a04094d5ed40f3f047ff2b7a613d4d530d4.tar.gz
libguestfs-87ea7a04094d5ed40f3f047ff2b7a613d4d530d4.tar.xz
libguestfs-87ea7a04094d5ed40f3f047ff2b7a613d4d530d4.zip
New btrfs APIs.
Bind the easy parts of the 'btrfs' program. The new APIs are: btrfs-device-add: add devices to a btrfs filesystem btrfs-device-delete: remove devices from a btrfs filesystem btrfs-filesystem-sync: sync a btrfs filesystem btrfs-filesystem-balance: balance a btrfs filesystem btrfs-subvolume-create: create a btrfs snapshot btrfs-subvolume-delete: delete a btrfs snapshot btrfs-subvolume-list: list btrfs snapshots and subvolumes btrfs-subvolume-set-default: set default btrfs subvolume btrfs-subvolume-snapshot: create a writable btrfs snapshot
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 32999808..ae0ea3ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,6 +42,7 @@ SUBDIRS += tests/lvm
SUBDIRS += tests/luks
SUBDIRS += tests/md
SUBDIRS += tests/ntfsclone
+SUBDIRS += tests/btrfs
SUBDIRS += tests/regressions
endif