summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-05-19 12:29:04 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-05-19 12:29:04 +0100
commit7b309445d4e9f93088ca052469338c8e3ce8dcbf (patch)
treee74bd8870a2e06acea3b0b0ddc5849d2fd814af2 /Makefile.am
parent4c7183285105fd74496133c059a093b78dbe7723 (diff)
downloadlibguestfs-7b309445d4e9f93088ca052469338c8e3ce8dcbf.tar.gz
libguestfs-7b309445d4e9f93088ca052469338c8e3ce8dcbf.tar.xz
libguestfs-7b309445d4e9f93088ca052469338c8e3ce8dcbf.zip
Skip 'zerofree' test if the command doesn't exist in the appliance.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 50c9e7d4..c035977d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,6 +105,7 @@ tests_LDADD = $(top_builddir)/src/libguestfs.la
TESTS = tests
TESTS_ENVIRONMENT = \
SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
+ SKIP_ZEROFREE=$(shell test -x initramfs/usr/sbin/zerofree || echo 1) \
$(VG)
$(TESTS): $(INITRAMFS) $(VMLINUZ)