summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-08-04 19:24:30 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-08-11 14:18:29 +0100
commit589db4e42ad5e759041521e7673bd7aa2f800736 (patch)
treebf56c353d76219623df9f0d626ed05f7b7541408 /Makefile.am
parent198cc630f0634fa318c6943f8de6706951701250 (diff)
downloadlibguestfs-589db4e42ad5e759041521e7673bd7aa2f800736.tar.gz
libguestfs-589db4e42ad5e759041521e7673bd7aa2f800736.tar.xz
libguestfs-589db4e42ad5e759041521e7673bd7aa2f800736.zip
Convert release notes to a POD file / man page.
Note that we add the text version to git so that it's available for people to read without requiring any special tools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 24 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 803aec83..5c76075b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,7 +119,7 @@ endif
EXTRA_DIST = \
$(generator_built) \
- BUGS HACKING RELEASE-NOTES ROADMAP TODO \
+ BUGS HACKING ROADMAP TODO \
.gitignore \
bugs-in-changelog.sh \
autogen.sh \
@@ -142,6 +142,7 @@ EXTRA_DIST = \
contrib/visualize-alignment/qemu-0.13-trace-block-device-access.patch \
contrib/visualize-alignment/README \
contrib/visualize-alignment/tracetops.ml \
+ guestfs-release-notes.pod \
html/pod.css \
libtool-kill-dependency_libs.sh \
logo/fish.svg logo/fish.png \
@@ -160,6 +161,7 @@ HTMLFILES = \
html/guestfs-perl.3.html \
html/guestfs-python.3.html \
html/guestfs-recipes.1.html \
+ html/guestfs-release-notes.1.html \
html/guestfs-ruby.3.html \
html/guestfs-testing.1.html \
html/guestfish.1.html \
@@ -188,7 +190,7 @@ HTMLFILES = \
html/virt-tar-out.1.html \
html/virt-win-reg.1.html
-TEXTFILES = BUGS README RELEASE-NOTES ROADMAP TODO
+TEXTFILES = BUGS README ROADMAP TODO
WEBSITEDIR = $(HOME)/d/redhat/websites/libguestfs
@@ -243,11 +245,30 @@ all-local:
find resize sparsify sysprep -name '*.ml' | \
LC_ALL=C sort > po/POTFILES-ml
+# Manual pages in top level directory.
+
+man_MANS = \
+ guestfs-release-notes.1
+noinst_DATA = \
+ $(top_builddir)/html/guestfs-release-notes.1.html
+
+guestfs-release-notes.1 $(top_builddir)/html/guestfs-release-notes.1.html: stamp-guestfs-release-notes.pod
+
+stamp-guestfs-release-notes.pod: guestfs-release-notes.pod
+ $(PODWRAPPER) \
+ --section 1 \
+ --man guestfs-release-notes.1 \
+ --text guestfs-release-notes.txt \
+ --html $(top_builddir)/html/guestfs-release-notes.1.html \
+ $<
+ touch $@
+
# Make clean.
CLEANFILES = \
pod2htm?.tmp \
- html/*.html
+ html/*.html \
+ stamp-guestfs-release-notes.pod
# If you don't want to run all of the tests ('make check') then this
# will just run libguestfs-test-tool for a quick check. Note this