summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-25 12:20:15 +0100
committerRichard Jones <rjones@redhat.com>2009-04-25 12:20:15 +0100
commit396bc943ed9cb7c6df091b18bc2eebe93ccc27d1 (patch)
tree60ea5c26fab20de4fc32835051dfc2d8ea441055 /Makefile.am
parentb86d7b975629ae099ad9a137ced6f23b17c1531a (diff)
downloadlibguestfs-396bc943ed9cb7c6df091b18bc2eebe93ccc27d1.tar.gz
libguestfs-396bc943ed9cb7c6df091b18bc2eebe93ccc27d1.tar.xz
libguestfs-396bc943ed9cb7c6df091b18bc2eebe93ccc27d1.zip
Improve CSS on recipes page.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index c0c2ebbe..40e7980f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,7 +49,8 @@ EXTRA_DIST = \
recipes/README \
recipes/*.html \
recipes/*.sh \
- recipes/*.example
+ recipes/*.example \
+ html/recipes.css
# Build the root filesystem.
# Currently this is arch-dependent, so it seems like putting it in
@@ -144,9 +145,7 @@ html/guestfish.1.html: guestfish.pod guestfish-actions.pod
html/recipes.html: $(wildcard recipes/*.sh) $(wildcard recipes/*.html) $(wildcard recipes/*.example) Makefile
rm -f $@ $@-t
echo '<html><head><title>guestfish recipes</title>' >> $@-t; \
- echo '<link rel="stylesheet" href="http://et.redhat.com/~rjones/css/standard.css" type="text/css" title="Standard"/>' >> $@-t; \
- echo '<link rel="stylesheet" href="http://et.redhat.com/~rjones/css/numbering.css" type="text/css" title="Standard"/>' >> $@-t; \
- echo '<link rel="alternate stylesheet" href="http://et.redhat.com/~rjones/css/easytoread.css" type="text/css" title="High contrast, big fonts"/>' >> $@-t; \
+ echo '<link rel="stylesheet" href="recipes.css" type="text/css" title="Standard"/>' >> $@-t; \
echo '</head><body>' >> $@-t; \
echo '<h1>guestfish recipes</h1>' >> $@-t; \
echo '<p>You can also find these in the <code>recipes/</code> subdirectory of the source.</p>' >> $@-t; \
@@ -158,7 +157,7 @@ html/recipes.html: $(wildcard recipes/*.sh) $(wildcard recipes/*.html) $(wildcar
else \
echo '<h2>$$b</h2>' >> $@-t; \
fi; \
- echo '<pre>' >> $@-t; \
+ echo '<pre class="example">' >> $@-t; \
sed -e 's,&,\&amp;,g' -e 's,<,\&lt;,g' -e 's,>,\&gt;,g' < $$f >> $@-t; \
echo '</pre>' >> $@-t; \
if [ -r recipes/$$b.example ]; then \
@@ -172,7 +171,8 @@ html/recipes.html: $(wildcard recipes/*.sh) $(wildcard recipes/*.html) $(wildcar
mv $@-t $@
website: html/guestfs.3.html html/guestfish.1.html html/recipes.html
- cp $^ html/pod.css $(HOME)/d/redhat/et-website/libguestfs/
+ cp $^ html/pod.css html/recipes.css \
+ $(HOME)/d/redhat/et-website/libguestfs/
# Generate the ChangeLog automatically from the gitlog.