summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-09 16:48:46 +0100
committerRichard Jones <rjones@redhat.com>2009-04-09 16:48:46 +0100
commit233595cc4e3c3422a5f5d8aec3314029da3f0ec7 (patch)
treec13d144c7a0b47ded862f37617d76660c865ac8c /Makefile.am
parente7eca50046e9a69dac27c0bee832af0a3014e02c (diff)
downloadlibguestfs-233595cc4e3c3422a5f5d8aec3314029da3f0ec7.tar.gz
libguestfs-233595cc4e3c3422a5f5d8aec3314029da3f0ec7.tar.xz
libguestfs-233595cc4e3c3422a5f5d8aec3314029da3f0ec7.zip
Generate webpages.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 33 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 241a0a8d..3a186001 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,13 +60,6 @@ $(INITRAMFSIMG): initramfs/fakeroot.log daemon/guestfsd
bash $(builddir)/update-initramfs.sh
touch $@
-# Make clean.
-
-CLEANFILES = $(fs_DATA) emptydisk
-
-clean-local:
- rm -rf initramfs
-
# Manual pages.
# guestfs-actions.pod and guestfs-structs are autogenerated. There is
# no include mechanism for POD, so we have to do it by hand.
@@ -96,6 +89,32 @@ guestfish.1: guestfish.pod guestfish-actions.pod
--release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
> $@
+noinst_DATA = html/guestfs.3.html html/guestfish.1.html
+
+html/guestfs.3.html: guestfs.pod guestfs-actions.pod guestfs-structs.pod
+ sed \
+ -e '/@ACTIONS@/rguestfs-actions.pod' -e 's/@ACTIONS@//' \
+ -e '/@STRUCTS@/rguestfs-structs.pod' -e 's/@STRUCTS@//' \
+ < $< | \
+ pod2html \
+ --css 'pod.css' \
+ --title "libguestfs API documentation" \
+ --htmldir html \
+ --outfile $@
+
+html/guestfish.1.html: guestfish.pod guestfish-actions.pod
+ sed \
+ -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+ < $< | \
+ pod2html \
+ --css 'pod.css' \
+ --title "guestfish, libguestfs filesystem interactive shell" \
+ --htmldir html \
+ --outfile $@
+
+website: html/guestfs.3.html html/guestfish.1.html
+ cp $^ html/pod.css $(HOME)/d/redhat/et-website/libguestfs/
+
# Test-boot the image.
test-boot: emptydisk
@@ -123,3 +142,10 @@ test-boot-realistic: emptydisk
-net channel,6666:unix:/tmp/sock,server,nowait \
-net user,vlan=0 \
-net nic,vlan=0
+
+# Make clean.
+
+CLEANFILES = $(fs_DATA) emptydisk pod2htm?.tmp
+
+clean-local:
+ rm -rf initramfs