summaryrefslogtreecommitdiffstats
path: root/regedit/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-03-26 11:46:44 +0000
committerRichard Jones <rjones@redhat.com>2010-03-30 11:58:45 +0100
commit70760da7f41e0ebc45122090ed624a6fea60b5d7 (patch)
treecaf1e998b3bbbec27ce05d67c92bbade115b11d3 /regedit/Makefile.am
parent3b713ed4f5d6ccb06660da1c0ff34762b1627669 (diff)
downloadhivex-70760da7f41e0ebc45122090ed624a6fea60b5d7.tar.gz
hivex-70760da7f41e0ebc45122090ed624a6fea60b5d7.tar.xz
hivex-70760da7f41e0ebc45122090ed624a6fea60b5d7.zip
hivexregedit: Low-level tool for merging and export in regedit format.
Diffstat (limited to 'regedit/Makefile.am')
-rw-r--r--regedit/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/regedit/Makefile.am b/regedit/Makefile.am
new file mode 100644
index 0000000..ab286cd
--- /dev/null
+++ b/regedit/Makefile.am
@@ -0,0 +1,43 @@
+# hivex
+# Copyright (C) 2010 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ hivexregedit \
+ run-locally
+
+bin_SCRIPTS = hivexregedit
+
+man_MANS = hivexregedit.1
+
+hivexregedit.1: hivexregedit
+ $(POD2MAN) \
+ --section 1 \
+ -c "Windows Registry" \
+ --name "hivexregedit" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@-t; mv $@-t $@
+
+noinst_DATA = \
+ $(top_builddir)/html/hivexregedit.1.html
+
+$(top_builddir)/html/hivexregedit.1.html: hivexregedit
+ mkdir -p $(top_builddir)/html
+ cd $(top_builddir) && pod2html \
+ --css 'pod.css' \
+ --htmldir html \
+ --outfile html/hivexregedit.1.html \
+ regedit/hivexregedit