summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-02-23 10:36:51 +0000
committerRichard Jones <rjones@redhat.com>2010-02-24 18:51:04 +0000
commitaa5d6c138b55e25994ac723e94f32b009366927c (patch)
tree7f44afd830cd788d9ff99a8ddb7881da083e5ef3 /python/Makefile.am
parentffd32d61d4fad969a6a0baec8c15774eac5ea2e2 (diff)
downloadhivex-aa5d6c138b55e25994ac723e94f32b009366927c.tar.gz
hivex-aa5d6c138b55e25994ac723e94f32b009366927c.tar.xz
hivex-aa5d6c138b55e25994ac723e94f32b009366927c.zip
Add build framework for OCaml, Perl, Python bindings.
(No bindings are actually built, this just adds the build, test and generator framework for them).
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
new file mode 100644
index 0000000..bc9ce7c
--- /dev/null
+++ b/python/Makefile.am
@@ -0,0 +1,45 @@
+# hivex Python bindings
+# Copyright (C) 2009-2010 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+# Old RHEL 5 autoconf doesn't have builddir.
+builddir ?= $(top_builddir)/python
+
+EXTRA_DIST = \
+ run-python-tests \
+ hivex.py \
+ hivex-py.c \
+ t/*.py
+
+if HAVE_PYTHON
+
+pythondir = $(PYTHON_SITE_PACKAGES)
+
+python_DATA = hivex.py
+
+python_LTLIBRARIES = libhivexmod.la
+
+libhivexmod_la_SOURCES = hivex-py.c
+libhivexmod_la_CFLAGS = -Wall -I$(PYTHON_INCLUDEDIR) \
+ -I$(top_srcdir)/lib -I$(top_builddir)/lib
+libhivexmod_la_LIBADD = $(top_builddir)/lib/libhivex.la
+
+TESTS_ENVIRONMENT = \
+ PYTHONPATH=$(builddir):$(builddir)/.libs
+
+TESTS = run-python-tests
+
+endif