summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-02-23 12:27:19 +0000
committerRichard Jones <rjones@redhat.com>2010-02-24 19:14:19 +0000
commit095c395082d1aad1e8558aa25514ad911e6d193c (patch)
treee068d0de9e18ac520d106c6cb857e87d67122c57 /ocaml/Makefile.am
parentaa5d6c138b55e25994ac723e94f32b009366927c (diff)
downloadhivex-095c395082d1aad1e8558aa25514ad911e6d193c.tar.gz
hivex-095c395082d1aad1e8558aa25514ad911e6d193c.tar.xz
hivex-095c395082d1aad1e8558aa25514ad911e6d193c.zip
generator: Add OCaml bindings.
Also we tighten up the definition of hivex_close (it disposes of handles) and hivex_node_get_child (unusual "not found" non-error condition). This also adds tests of the OCaml bindings.
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index f7d26ce..b3f5e14 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -49,13 +49,44 @@ TESTS_ENVIRONMENT = \
LD_LIBRARY_PATH=$(top_builddir)/lib/.libs \
$(VG)
-TESTS = t/hivex_005_load
+TESTS = \
+ t/hivex_005_load \
+ t/hivex_010_open \
+ t/hivex_020_root \
+ t/hivex_100_errors \
+ t/hivex_110_gc_handle \
+ t/hivex_200_write \
+ t/hivex_300_fold
noinst_DATA += $(TESTS)
t/hivex_005_load: t/hivex_005_load.cmx mlhivex.cmxa
mkdir -p t
$(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/lib/.libs -I . -package unix -linkpkg mlhivex.cmxa $< -o $@
+t/hivex_010_open: t/hivex_010_open.cmx mlhivex.cmxa
+ mkdir -p t
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/lib/.libs -I . -package unix -linkpkg mlhivex.cmxa $< -o $@
+
+t/hivex_020_root: t/hivex_020_root.cmx mlhivex.cmxa
+ mkdir -p t
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/lib/.libs -I . -package unix -linkpkg mlhivex.cmxa $< -o $@
+
+t/hivex_100_errors: t/hivex_100_errors.cmx mlhivex.cmxa
+ mkdir -p t
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/lib/.libs -I . -package unix -linkpkg mlhivex.cmxa $< -o $@
+
+t/hivex_110_gc_handle: t/hivex_110_gc_handle.cmx mlhivex.cmxa
+ mkdir -p t
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/lib/.libs -I . -package unix -linkpkg mlhivex.cmxa $< -o $@
+
+t/hivex_200_write: t/hivex_200_write.cmx mlhivex.cmxa
+ mkdir -p t
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/lib/.libs -I . -package unix -linkpkg mlhivex.cmxa $< -o $@
+
+t/hivex_300_fold: t/hivex_300_fold.cmx mlhivex.cmxa
+ mkdir -p t
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/lib/.libs -I . -package unix -linkpkg mlhivex.cmxa $< -o $@
+
# Need to rebuild the tests from source if the main library has
# changed at all, otherwise we get inconsistent assumptions.
t/%.cmx: t/%.ml mlhivex.cmxa