summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-08-27 08:51:37 +0100
committerRichard Jones <rjones@redhat.com>2010-08-27 08:51:37 +0100
commitccdf51171372b87f887f6320f966fc0c526c037b (patch)
tree92814779462d289952ef7d9735bdc8543c39176c /configure.ac
parentdb13b0e039da1e7fdb7eb7b9e3e0be645667d01a (diff)
downloadhivex-ccdf51171372b87f887f6320f966fc0c526c037b.tar.gz
hivex-ccdf51171372b87f887f6320f966fc0c526c037b.tar.xz
hivex-ccdf51171372b87f887f6320f966fc0c526c037b.zip
build: Don't warn about 'long long'.
We have to allow this, even though it's a GCC extension. This is a port of libguestfs commit 0c0976496dafda4d172c5a7fc787d6a87d5bce8d.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1efc7c1..7c599e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,6 +87,8 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wunsafe-loop-optimizations" # just a warning that an optimization
# was not possible, safe to ignore
nw="$nw -Wpacked" # Allow attribute((packed)) on structs
+ nw="$nw -Wlong-long" # Allow long long since it's required
+ # by xstrtoll.
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])