summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2011-05-12 00:04:19 +0200
committerRichard W.M. Jones <rjones@redhat.com>2011-05-12 10:50:48 +0100
commit5cf4fc2caa34ccb3a1e01bbec912158127dcd169 (patch)
tree299f294c47786cbba104521fb7f0796d71a634ec /configure.ac
parentc9c8f893ecfaa9d646dfd02b1e0f16c549bbb6cd (diff)
downloadhivex-5cf4fc2caa34ccb3a1e01bbec912158127dcd169.tar.gz
hivex-5cf4fc2caa34ccb3a1e01bbec912158127dcd169.tar.xz
hivex-5cf4fc2caa34ccb3a1e01bbec912158127dcd169.zip
hivex: check for presence of OCaml native compiler
Only compile bytecode otherwise, avoiding ocamlfind's helpful error message "ocamlfind: Not supported in your configuration: ocamlopt" (Successfully tested on Debian/unstable on alpha)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3e5c40..65aa538 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,6 +174,7 @@ dnl Check for OCaml (optional, for OCaml bindings).
AC_PROG_OCAML
AC_PROG_FINDLIB
AM_CONDITIONAL([HAVE_OCAML],[test "x$OCAMLC" != "xno" -a "x$OCAMLFIND" != "xno"])
+AM_CONDITIONAL([HAVE_OCAMLOPT], [test "x$OCAMLOPT" != "xno" -a "x$OCAMLFIND" != "xno"])
if test "x$OCAMLC" != "xno"; then
dnl Check if we have caml/unixsupport.h header (OCaml bindings only).