summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-04-03 16:06:58 +0100
committerRichard Jones <rjones@redhat.com>2010-04-03 16:06:58 +0100
commit5b637fb0bfa2faa357e08aab646e6c427c9f397c (patch)
tree52cf320708d3c25627b44487343628426fde71db /configure.ac
parent7614b64ca6c091d487a1b9c47462bd30be0f5445 (diff)
downloadhivex-5b637fb0bfa2faa357e08aab646e6c427c9f397c.tar.gz
hivex-5b637fb0bfa2faa357e08aab646e6c427c9f397c.tar.xz
hivex-5b637fb0bfa2faa357e08aab646e6c427c9f397c.zip
Add a linker script to limit visibility to exported symbols.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dda6892..52dbf6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,6 +116,12 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
AM_PROG_CC_C_O
+dnl Work out how to specify the linker script to the linker.
+VERSION_SCRIPT_FLAGS=-Wl,--version-script=
+`/usr/bin/ld --help 2>&1 | grep -- --version-script >/dev/null` || \
+ VERSION_SCRIPT_FLAGS="-Wl,-M -Wl,"
+AC_SUBST(VERSION_SCRIPT_FLAGS)
+
dnl Check support for 64 bit file offsets.
AC_SYS_LARGEFILE