summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-11-29 10:49:27 +0000
committerRichard W.M. Jones <rjones@redhat.com>2011-11-29 10:56:28 +0000
commit2751429ce2f3b7a6d2547abc36bed93fd075ece4 (patch)
tree18ec02c105cbfd00a3184ebac8f76dcc317947a0 /configure.ac
parentaad1c2dec4d2652803560ca1cafcb249bb14638f (diff)
downloadhivex-2751429ce2f3b7a6d2547abc36bed93fd075ece4.tar.gz
hivex-2751429ce2f3b7a6d2547abc36bed93fd075ece4.tar.xz
hivex-2751429ce2f3b7a6d2547abc36bed93fd075ece4.zip
Update to latest gnulib (RHBZ#756981).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 004efaa..ba1b887 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,9 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wpacked" # Allow attribute((packed)) on structs
nw="$nw -Wlong-long" # Allow long long since it's required
# by xstrtoll.
+ nw="$nw -Wsuggest-attribute=pure" # Don't suggest pure functions.
+# nw="$nw -Wsuggest-attribute=const" # Don't suggest const functions.
+# nw="$nw -Wunsuffixed-float-constants" # Don't care about these.
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])