summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-02-19 14:33:40 +0000
committerRichard Jones <rjones@redhat.com>2010-02-19 14:33:40 +0000
commitcb9cb9b7dcdf62310c7b543aaac0a82d7f4b9319 (patch)
tree4e3412605c02c3b234e5efca07dfb9770c14269c /Makefile.am
downloadhivex-cb9cb9b7dcdf62310c7b543aaac0a82d7f4b9319.tar.gz
hivex-cb9cb9b7dcdf62310c7b543aaac0a82d7f4b9319.tar.xz
hivex-cb9cb9b7dcdf62310c7b543aaac0a82d7f4b9319.zip
Support for Windows Registry.
In hivex/: This mini-library allows us to extract Windows Registry binary files ("hives"). There are also two tools: hivexml converts a hive to a self-describing XML format. hivexget can be used to extract single subkeys from a hive.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..64483d5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,47 @@
+# hivex
+# Copyright (C) 2009-2010 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = gnulib/lib hivex gnulib/tests
+
+EXTRA_DIST = hivex.pc hivex.pc.in
+
+# Generate the ChangeLog automatically from the gitlog.
+dist-hook:
+ $(top_srcdir)/build-aux/gitlog-to-changelog > ChangeLog
+ cp ChangeLog $(distdir)/ChangeLog
+
+# Update the list of translatable files in po/POTFILES.in.
+all-local:
+ cd $(srcdir); \
+ find $(DIST_SUBDIRS) \
+ -name '*.c' -o -name '*.pl' -o -name '*.pm' -o \
+ -name 'virt-cat' -o \
+ -name 'virt-df' -o \
+ -name 'virt-edit' -o \
+ -name 'virt-inspector' -o \
+ -name 'virt-ls' -o \
+ -name 'virt-rescue' -o \
+ -name 'virt-tar' | \
+ grep -v '^gnulib/' | \
+ LC_ALL=C sort | \
+ sed 's,^\./,,' > po/POTFILES.in
+
+# Pkgconfig.
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = hivex.pc