summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlex Nelson <ajnelson@cs.ucsc.edu>2011-09-06 20:42:44 -0700
committerRichard W.M. Jones <rjones@redhat.com>2011-09-07 13:15:30 +0100
commit0a28041f4156878a74543966f9a72ed3d214ba44 (patch)
treed60546b5aa38b135546428d6dbcddff938ec7e58 /Makefile.am
parent085707078097f6def993b20a794001d6c06f1492 (diff)
downloadhivex-0a28041f4156878a74543966f9a72ed3d214ba44.tar.gz
hivex-0a28041f4156878a74543966f9a72ed3d214ba44.tar.xz
hivex-0a28041f4156878a74543966f9a72ed3d214ba44.zip
hivexsh: Conditionally build for Mac OS X
OS X lacks open_memstream, causing hivexsh to fail to build. This patch defines HAVE_HIVEXSH, setting the only condition to open_memstream existence. Signed-off-by: Alex Nelson <ajnelson@cs.ucsc.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8d69c55..dbab38a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,11 @@ ACLOCAL_AMFLAGS = -I m4
# Work around broken libtool.
export to_tool_file_cmd=func_convert_file_noop
-SUBDIRS = gnulib/lib generator lib images gnulib/tests sh xml po
+SUBDIRS = gnulib/lib generator lib images gnulib/tests xml po
+
+if HAVE_HIVEXSH
+SUBDIRS += sh
+endif
if HAVE_OCAML
SUBDIRS += ocaml