summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b715c9f..2bcad79 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -73,7 +73,10 @@ depend: .depend
.depend: $(SOURCES)
rm -f $@ $@-t
- $(OCAMLFIND) ocamldep $^ > $@-t
+ $(OCAMLFIND) ocamldep $^ | \
+ $(SED) 's/ *$$//' | \
+ $(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
+ sort > $@-t
mv $@-t $@
include .depend