summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c23498b..b239bbf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,7 @@ SUBDIRS = examples
bin_SCRIPTS = \
febootstrap \
febootstrap-run \
+ febootstrap-install \
febootstrap-minimize \
febootstrap-to-initramfs
DISTCLEANFILES = $(bin_SCRIPTS)
@@ -38,6 +39,12 @@ febootstrap-run: febootstrap-run.sh
chmod 0555 $@-t
mv $@-t $@
+febootstrap-install: febootstrap-install.sh
+ rm -f $@
+ cp $< $@-t
+ chmod 0555 $@-t
+ mv $@-t $@
+
febootstrap-minimize: febootstrap-minimize.sh
rm -f $@
cp $< $@-t
@@ -53,6 +60,7 @@ febootstrap-to-initramfs: febootstrap-to-initramfs.sh
man_MANS = \
febootstrap.8 \
febootstrap-run.8 \
+ febootstrap-install.8 \
febootstrap-minimize.8 \
febootstrap-to-initramfs.8
@@ -78,6 +86,16 @@ febootstrap-run.8: febootstrap-run.pod
febootstrap-run.txt: febootstrap-run.pod
pod2text $< > $@
+febootstrap-install.8: febootstrap-install.pod
+ pod2man \
+ --section 8 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+febootstrap-install.txt: febootstrap-install.pod
+ pod2text $< > $@
+
febootstrap-minimize.8: febootstrap-minimize.pod
pod2man \
--section 8 \
@@ -107,6 +125,8 @@ EXTRA_DIST = \
febootstrap.sh \
febootstrap-run.8 febootstrap-run.txt febootstrap-run.pod \
febootstrap-run.sh \
+ febootstrap-install.8 febootstrap-install.txt febootstrap-install.pod \
+ febootstrap-install.sh \
febootstrap-minimize.8 febootstrap-minimize.txt \
febootstrap-minimize.pod \
febootstrap-minimize.sh \