summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-05-11 14:51:22 +0100
committerRichard Jones <rjones@redhat.com>2009-05-11 15:41:41 +0100
commitd52fcf7521b8f9b1ec7bbeaaf93840af37d363cf (patch)
tree2e40039898704b34c73c42fa02b27a043ec0fe60 /Makefile.am
parente8d2809e31c5f4c937dc98239118855b2d1d006e (diff)
downloadfebootstrap-d52fcf7521b8f9b1ec7bbeaaf93840af37d363cf.tar.gz
febootstrap-d52fcf7521b8f9b1ec7bbeaaf93840af37d363cf.tar.xz
febootstrap-d52fcf7521b8f9b1ec7bbeaaf93840af37d363cf.zip
Be more careful about removing files in fakeroot during minimization.
Added febootstrap-install program.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c23498b..b239bbf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,7 @@ SUBDIRS = examples
bin_SCRIPTS = \
febootstrap \
febootstrap-run \
+ febootstrap-install \
febootstrap-minimize \
febootstrap-to-initramfs
DISTCLEANFILES = $(bin_SCRIPTS)
@@ -38,6 +39,12 @@ febootstrap-run: febootstrap-run.sh
chmod 0555 $@-t
mv $@-t $@
+febootstrap-install: febootstrap-install.sh
+ rm -f $@
+ cp $< $@-t
+ chmod 0555 $@-t
+ mv $@-t $@
+
febootstrap-minimize: febootstrap-minimize.sh
rm -f $@
cp $< $@-t
@@ -53,6 +60,7 @@ febootstrap-to-initramfs: febootstrap-to-initramfs.sh
man_MANS = \
febootstrap.8 \
febootstrap-run.8 \
+ febootstrap-install.8 \
febootstrap-minimize.8 \
febootstrap-to-initramfs.8
@@ -78,6 +86,16 @@ febootstrap-run.8: febootstrap-run.pod
febootstrap-run.txt: febootstrap-run.pod
pod2text $< > $@
+febootstrap-install.8: febootstrap-install.pod
+ pod2man \
+ --section 8 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+febootstrap-install.txt: febootstrap-install.pod
+ pod2text $< > $@
+
febootstrap-minimize.8: febootstrap-minimize.pod
pod2man \
--section 8 \
@@ -107,6 +125,8 @@ EXTRA_DIST = \
febootstrap.sh \
febootstrap-run.8 febootstrap-run.txt febootstrap-run.pod \
febootstrap-run.sh \
+ febootstrap-install.8 febootstrap-install.txt febootstrap-install.pod \
+ febootstrap-install.sh \
febootstrap-minimize.8 febootstrap-minimize.txt \
febootstrap-minimize.pod \
febootstrap-minimize.sh \