summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am88
1 files changed, 3 insertions, 85 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ac5079..c40c769 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# febootstrap Makefile.am
-# (C) Copyright 2009-2010 Red Hat Inc.
+# (C) Copyright 2009-2011 Red Hat Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,98 +19,16 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = lib helper
-
-# Note these must be in build dependency order.
-SOURCES = \
- config.ml \
- febootstrap_cmdline.mli \
- febootstrap_cmdline.ml \
- febootstrap_utils.mli \
- febootstrap_utils.ml \
- febootstrap_package_handlers.mli \
- febootstrap_package_handlers.ml \
- febootstrap_yum_rpm.ml \
- febootstrap_debian.ml \
- febootstrap_pacman.ml \
- febootstrap.ml
-
-CLEANFILES = *~ *.cmi *.cmo *.cmx *.o febootstrap
+SUBDIRS = lib src helper
EXTRA_DIST = \
.gitignore \
.gitmodules \
autogen.sh \
- febootstrap.8 \
- febootstrap.pod \
html/pod.css \
m4/gnulib-cache.m4 \
$(SOURCES)
-man_MANS = \
- febootstrap.8
-
-bin_SCRIPTS = febootstrap
-
-SOURCES_ML = $(filter %.ml,$(SOURCES))
-BOBJECTS = $(SOURCES_ML:.ml=.cmo)
-XOBJECTS = $(SOURCES_ML:.ml=.cmx)
-
-if !HAVE_OCAMLOPT
-OBJECTS = $(BOBJECTS)
-BEST = c
-else
-OBJECTS = $(XOBJECTS)
-BEST = opt
-endif
-
-OCAMLPACKAGES = -package unix,str
-OCAMLFLAGS = -warn-error CDEFLMPSUVXYZ
-
-febootstrap: $(OBJECTS)
- $(OCAMLFIND) $(BEST) $(OCAMLFLAGS) $(OCAMLPACKAGES) -linkpkg \
- $^ -o $@
-
-.mli.cmi:
- $(OCAMLFIND) ocamlc $(OCAMLFLAGS) $(OCAMLPACKAGES) -c $< -o $@
-.ml.cmo:
- $(OCAMLFIND) ocamlc $(OCAMLFLAGS) $(OCAMLPACKAGES) -c $< -o $@
-.ml.cmx:
- $(OCAMLFIND) ocamlopt $(OCAMLFLAGS) $(OCAMLPACKAGES) -c $< -o $@
-
-depend: .depend
-
-.depend: $(SOURCES)
- rm -f $@ $@-t
- $(OCAMLFIND) ocamldep $^ > $@-t
- mv $@-t $@
-
-include .depend
-
-SUFFIXES = .cmo .cmi .cmx .ml .mli .mll .mly
-
-if HAVE_PERLDOC
-
-febootstrap.8: febootstrap.pod
- pod2man \
- --section 8 \
- -c "Virtualization Support" \
- --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
- $< > $@
-
-noinst_DATA = \
- html/febootstrap.8.html
-
-html/febootstrap.8.html: febootstrap.pod
- mkdir -p html
- pod2html \
- --css 'pod.css' \
- --htmldir html \
- --outfile html/febootstrap.8.html \
- febootstrap.pod
-
-endif
-
# Maintainer website update.
HTMLFILES = \
html/febootstrap.8.html \
@@ -121,4 +39,4 @@ WEBSITEDIR = $(HOME)/d/redhat/websites/libguestfs
website: $(HTMLFILES)
cp $(HTMLFILES) $(WEBSITEDIR)
-CLEANFILES += $(HTMLFILES) pod2*.tmp
+CLEANFILES = $(HTMLFILES) pod2*.tmp