summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-05-13 13:29:20 +0100
committerRichard Jones <rjones@redhat.com>2010-05-14 11:41:28 +0100
commit95dd28aadbfc1f058dae26beea949cf3cbc22b26 (patch)
treea22f2dbcd2a450c339a0aaf371e2c8f437500d98 /Makefile.am
parent3c9a5248737321d174aefcb9cb8251e1ab44c3fa (diff)
downloadfebootstrap-95dd28aadbfc1f058dae26beea949cf3cbc22b26.tar.gz
febootstrap-95dd28aadbfc1f058dae26beea949cf3cbc22b26.tar.xz
febootstrap-95dd28aadbfc1f058dae26beea949cf3cbc22b26.zip
Pull in febootstrap-supermin-helper (C version) from libguestfs.2.7
This commit also pulls in the automake C dependencies and gnulib. febootstrap-supermin-helper is modified so that it has the --kmods option (to read the whitelist, from the old shell script), and so that it can read supermin appliances composed of multiple parts from out of a directory. Also: Updates to documentation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 861b5e0..bb3b505 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# febootstrap Makefile.am
-# (C) Copyright 2009 Red Hat Inc.
+# (C) Copyright 2009-2010 Red Hat Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -17,7 +17,9 @@
#
# Written by Richard W.M. Jones <rjones@redhat.com>
-SUBDIRS = examples
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = lib examples
bin_SCRIPTS = \
febootstrap \
@@ -25,7 +27,8 @@ bin_SCRIPTS = \
febootstrap-install \
febootstrap-minimize \
febootstrap-to-initramfs \
- febootstrap-to-supermin \
+ febootstrap-to-supermin
+bin_PROGRAMS = \
febootstrap-supermin-helper
DISTCLEANFILES = $(bin_SCRIPTS)
@@ -65,11 +68,9 @@ febootstrap-to-supermin: febootstrap-to-supermin.sh
chmod 0555 $@-t
mv $@-t $@
-febootstrap-supermin-helper: febootstrap-supermin-helper.sh
- rm -f $@
- cp $< $@-t
- chmod 0555 $@-t
- mv $@-t $@
+febootstrap_supermin_helper_SOURCES = febootstrap-supermin-helper.c
+febootstrap_supermin_helper_CFLAGS = -Wall -Ilib
+febootstrap_supermin_helper_LDADD = $(LTLIBINTL) -Llib -lgnu
man_MANS = \
febootstrap.8 \
@@ -174,4 +175,4 @@ EXTRA_DIST = \
febootstrap-to-supermin.sh \
febootstrap-supermin-helper.8 febootstrap-supermin-helper.txt \
febootstrap-supermin-helper.pod \
- febootstrap-supermin-helper.sh
+ m4/gnulib-cache.m4