summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-12-07 18:56:45 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-07 18:57:56 +0000
commit5574d14658535b22e8f6141b92d8af1e4df037c0 (patch)
tree74642609d03a5056b19da0a21356626f656d5313 /Makefile.am
parent75c179dbaaa744c493e5e02bdcfbfc874e25766b (diff)
downloadfebootstrap-5574d14658535b22e8f6141b92d8af1e4df037c0.tar.gz
febootstrap-5574d14658535b22e8f6141b92d8af1e4df037c0.tar.xz
febootstrap-5574d14658535b22e8f6141b92d8af1e4df037c0.zip
Add HTML documentation to the public website.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d04412c..168bb47 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,4 +94,28 @@ febootstrap.8: febootstrap.pod
-c "Virtualization Support" \
--release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
$< > $@
+
+noinst_DATA = \
+ html/febootstrap.8.html
+
+html/febootstrap.8.html: febootstrap.pod
+ mkdir -p html
+ pod2html \
+ --css 'pod.css' \
+ --htmldir html \
+ --outfile html/febootstrap.8.html \
+ febootstrap.pod
+
endif
+
+# Maintainer website update.
+HTMLFILES = \
+ html/febootstrap.8.html \
+ html/febootstrap-supermin-helper.8.html
+
+WEBSITEDIR = $(HOME)/d/redhat/websites/libguestfs
+
+website: $(HTMLFILES)
+ cp $(HTMLFILES) $(WEBSITEDIR)
+
+CLEANFILES += $(HTMLFILES) pod2*.tmp