summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorrjones <rjones>2009-03-20 11:01:39 +0000
committerrjones <rjones>2009-03-20 11:01:39 +0000
commit1b640fb0bd84f88d378b6c4a74088ac22c8f7d75 (patch)
treeeff1b6ec217a57102ca8a84d9f0f70d6aa44fc40 /Makefile.am
parentdc60cc1bb950870269252135186e69d2ba4db994 (diff)
downloadfebootstrap-1b640fb0bd84f88d378b6c4a74088ac22c8f7d75.tar.gz
febootstrap-1b640fb0bd84f88d378b6c4a74088ac22c8f7d75.tar.xz
febootstrap-1b640fb0bd84f88d378b6c4a74088ac22c8f7d75.zip
Add first version of the febootstrap-minimize script.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 22 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c7cfcc..afa11f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,10 @@
SUBDIRS = examples
-bin_SCRIPTS = febootstrap febootstrap-to-initramfs
+bin_SCRIPTS = \
+ febootstrap \
+ febootstrap-minimize \
+ febootstrap-to-initramfs
febootstrap: febootstrap.sh
rm -f $@
@@ -27,15 +30,25 @@ febootstrap: febootstrap.sh
chmod 0555 $@-t
mv $@-t $@
+febootstrap-minimize: febootstrap-minimize.sh
+ rm -f $@
+ cp $< $@-t
+ chmod 0555 $@-t
+ mv $@-t $@
+
febootstrap-to-initramfs: febootstrap-to-initramfs.sh
rm -f $@
cp $< $@-t
chmod 0555 $@-t
mv $@-t $@
-man_MANS = febootstrap.8 febootstrap-to-initramfs.8 febootstrap-fix-root.8
+man_MANS = \
+ febootstrap.8 \
+ febootstrap-minimize.8 \
+ febootstrap-to-initramfs.8
if HAVE_PERLDOC
+
febootstrap.8: febootstrap.pod
pod2man \
--section 8 \
@@ -46,32 +59,33 @@ febootstrap.8: febootstrap.pod
febootstrap.txt: febootstrap.pod
pod2text $< > $@
-febootstrap-to-initramfs.8: febootstrap-to-initramfs.pod
+febootstrap-minimize.8: febootstrap-minimize.pod
pod2man \
--section 8 \
-c "Virtualization Support" \
--release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
$< > $@
-febootstrap-to-initramfs.txt: febootstrap-to-initramfs.pod
+febootstrap-minimize.txt: febootstrap-minimize.pod
pod2text $< > $@
-febootstrap-fix-root.8: febootstrap-fix-root.pod
+febootstrap-to-initramfs.8: febootstrap-to-initramfs.pod
pod2man \
--section 8 \
-c "Virtualization Support" \
--release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
$< > $@
-febootstrap-fix-root.txt: febootstrap-fix-root.pod
+febootstrap-to-initramfs.txt: febootstrap-to-initramfs.pod
pod2text $< > $@
+
endif
EXTRA_DIST = \
fakechroot-2.8-relchroot.patch \
febootstrap.8 febootstrap.txt febootstrap.pod \
+ febootstrap-minimize.8 febootstrap-minimize.txt \
+ febootstrap-minimize.pod \
febootstrap-to-initramfs.8 febootstrap-to-initramfs.txt \
febootstrap-to-initramfs.pod \
- febootstrap-fix-root.8 febootstrap-fix-root.txt \
- febootstrap-fix-root.pod \
febootstrap.sh febootstrap-to-initramfs.sh