summaryrefslogtreecommitdiffstats
path: root/conf/redhat/puppet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'conf/redhat/puppet.spec')
-rw-r--r--conf/redhat/puppet.spec12
1 files changed, 9 insertions, 3 deletions
diff --git a/conf/redhat/puppet.spec b/conf/redhat/puppet.spec
index 92a42ce7b..b5090ed38 100644
--- a/conf/redhat/puppet.spec
+++ b/conf/redhat/puppet.spec
@@ -2,7 +2,7 @@
%define pbuild %{_builddir}/%{name}-%{version}
%define confdir conf/redhat
-%define has_ruby_abi 0%{?fedora:%fedora} >= 5 || 0%{?rhel:%rhel} >= 5
+%define has_ruby_abi 0%{?fedora:%fedora} >= 5 || 0%{?rhel:%rhel} >= 5 || 0%{?centos:%centos} >= 5
%define has_ruby_noarch %has_ruby_abi
Summary: A network tool for managing many disparate systems
@@ -51,8 +51,8 @@ done
# Fix some rpmlint complaints
for f in mac_dscl.pp mac_dscl_revert.pp \
mac_netinfo.pp mac_pkgdmg.pp ; do
- sed -i -e'1d' examples/code/$f
- chmod a-x examples/code/$f
+ sed -i -e'1d' examples/$f
+ chmod a-x examples/$f
done
find examples/ -type f -empty | xargs rm
@@ -65,6 +65,7 @@ install -d -m0755 %{buildroot}%{_bindir}
install -d -m0755 %{buildroot}%{ruby_sitelibdir}
install -d -m0755 %{buildroot}%{_sysconfdir}/puppet/manifests
install -d -m0755 %{buildroot}%{_docdir}/%{name}-%{version}
+install -d -m0755 %{buildroot}%{_mandir}/man8
install -d -m0755 %{buildroot}%{_localstatedir}/lib/puppet
install -d -m0755 %{buildroot}%{_localstatedir}/run/puppet
install -d -m0755 %{buildroot}%{_localstatedir}/log/puppet
@@ -84,6 +85,7 @@ install -Dp -m0755 %{confdir}/server.init %{buildroot}%{_initrddir}/puppetmaster
install -Dp -m0644 %{confdir}/fileserver.conf %{buildroot}%{_sysconfdir}/puppet/fileserver.conf
install -Dp -m0644 %{confdir}/puppet.conf %{buildroot}%{_sysconfdir}/puppet/puppet.conf
install -Dp -m0644 %{confdir}/logrotate %{buildroot}%{_sysconfdir}/logrotate.d/puppet
+install -Dp -m0644 man/man8/* %{buildroot}%{_mandir}/man8
# We need something for these ghosted files, otherwise rpmbuild
# will complain loudly. They won't be included in the binary packages
touch %{buildroot}%{_sysconfdir}/puppet/puppetmasterd.conf
@@ -128,6 +130,10 @@ touch %{buildroot}%{_sysconfdir}/puppet/puppetd.conf
%ghost %config(noreplace,missingok) %{_sysconfdir}/puppet/puppetca.conf
%ghost %config(noreplace,missingok) %{_sysconfdir}/puppet/puppetmasterd.conf
%{_sbindir}/puppetca
+%doc %{_mandir}/man8/filebucket.8.gz
+%doc %{_mandir}/man8/puppetca.8.gz
+%doc %{_mandir}/man8/puppetmasterd.8.gz
+%doc %{_mandir}/man8/puppetrun.8.gz
%pre
/usr/sbin/groupadd -r puppet 2>/dev/null || :