summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2015-10-01 13:58:12 -0400
committerRob Crittenden <rcritten@redhat.com>2015-10-02 16:51:56 -0400
commitd536eae8b69e500a9d20954c102e05d7ba676566 (patch)
tree388981e87846b8ca983d3a60fc543b2ee1c18660 /Makefile.am
parent555dac5e98ac73496fc5cf9a147489a0479f2bfd (diff)
downloadmod_nss-d536eae8b69e500a9d20954c102e05d7ba676566.tar.gz
mod_nss-d536eae8b69e500a9d20954c102e05d7ba676566.tar.xz
mod_nss-d536eae8b69e500a9d20954c102e05d7ba676566.zip
Modernize autotools configuration slightly, add config.h
I need to generate config.h because Apache ships its own autotools-generated config.h which redefines a lot of variables like PACKAGE_NAME, PACKAGE_TARBALL, etc. By having my own configh I can reset things before the compiler complains. The downside is that compile-time options are hidden in a config file instead of being defined on the gcc command-line.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ca89989..602c25e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,3 @@
-VERSION = 1.0.11
-
## This is the shared library to be built
lib_LTLIBRARIES = libmodnss.la
@@ -23,7 +21,7 @@ libmodnss_la_SOURCES = mod_nss.c nss_engine_config.c nss_engine_init.c nss_engin
libmodnss_la_LDFLAGS = -module -avoid-version
## Set the includes and libraries needed
-INCLUDES = -I@apache_inc@ @nspr_inc@ @nss_inc@ @apr_inc@
+AM_CPPFLAGS = -I@apache_inc@ @nspr_inc@ @nss_inc@ @apr_inc@
LIBS = @nspr_lib@ @nss_lib@ -lssl3 -lsmime3 -lnss3 -lplc4 -lplds4 -lnspr4
EXTRA_CPPFLAGS=@extra_cppflags@