summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2014-10-28 17:41:22 -0400
committerRob Crittenden <rcritten@redhat.com>2014-10-28 17:41:22 -0400
commitb5d1505fc81a33aa10d013efd247d00f631fc681 (patch)
treef840f8450cdd70b5143ad45eab6d87b3ef630492 /Makefile.am
parent0d4c4e31e3f55473569c4e937f432d6f20c9d6be (diff)
downloadmod_nss-b5d1505fc81a33aa10d013efd247d00f631fc681.tar.gz
mod_nss-b5d1505fc81a33aa10d013efd247d00f631fc681.tar.xz
mod_nss-b5d1505fc81a33aa10d013efd247d00f631fc681.zip
Add support for sqlite NSS databases
We do a chdir() to the NSS database location so that libnssckbi.so is available when the database is opened. Strip off a sql: prefix if one is available. This allows the new sqlite format to work. Add an additional test pass configuring NSS using the sqlite format. This requires a bit of a hack to pass in the value to python but it will work for now. Resolves: #1057650
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 986048d..fbfa62d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,8 +98,13 @@ EXTRA_DIST = *.h *.8 LICENSE test docs
check:
cd test; \
+ rm -rf work; \
./setup.sh; \
nosetests -v; \
+ sleep 5; \
+ rm -rf work; \
+ ./setup.sh sql:; \
+ DBPREFIX=sql: nosetests -v; \
cd ..
.PHONY: all test clean