summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2015-09-25 09:12:00 -0400
committerRob Crittenden <rcritten@redhat.com>2015-10-02 16:51:56 -0400
commit15af3be170f05b64a967f4f7755a90608033c374 (patch)
treed0448ee439e6229580459fc55d532e807856da9b /Makefile.am
parent00fe09480dfd28674661830d8a045e0f560bbe51 (diff)
downloadmod_nss-15af3be170f05b64a967f4f7755a90608033c374.tar.gz
mod_nss-15af3be170f05b64a967f4f7755a90608033c374.tar.xz
mod_nss-15af3be170f05b64a967f4f7755a90608033c374.zip
Add test suite for SNI
python for OpenSSL is in quite a sad state with several competing mid-level implementations which provide different feature sets. The httplib client provides access to the negotiated cipher and protocol but not SNI (and it has lousy hostname checking). The urllib3 client provides SNI and is generally better but doesn't give any details on the connection. So I'm using both. The original one is used for basic server testing and the urllib3 one is used just for SNI testing. Also: - Indent the test configuration to make it more readable - Add separate config file for SNI testing - Add a CGI configuration and script to test CGI variables - Change client cipher test to use AES256-SHA instead of RC4 - Add a commented-out valgrind option in start for future debuggers - Change the VirtualServers to *:port and use ServerName - Add per-VH document roots so SNI can be more easily tested
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4978ff3..ca89989 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,12 +103,20 @@ check:
cd test; \
rm -rf work; \
nosetests -v test_cipher.py; \
- ./setup.sh; \
+ ./setup.sh -s 1; \
nosetests -v test.py; \
sleep 5; \
rm -rf work; \
- ./setup.sh sql:; \
+ ./setup.sh sql: -s 1; \
DBPREFIX=sql: nosetests -v test.py; \
cd ..
+checksni:
+ cd test; \
+ rm -rf work; \
+ ./setup.sh -s 25; \
+ nosetests -v testsni.py; \
+ cd ..
+
+
.PHONY: all test clean