summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2014-02-26 16:37:51 -0500
committerRob Crittenden <rcritten@redhat.com>2014-02-26 16:50:55 -0500
commit07c27296c2c940cb119386304ebffb4ab41f0fb9 (patch)
tree201d87fb7f87d734bcec06aef66d8f20d8fb4706 /Makefile.am
parentc2ac0d128e776f3edb8aeb8920bf41b99742e74c (diff)
downloadmod_nss-07c27296c2c940cb119386304ebffb4ab41f0fb9.tar.gz
mod_nss-07c27296c2c940cb119386304ebffb4ab41f0fb9.tar.xz
mod_nss-07c27296c2c940cb119386304ebffb4ab41f0fb9.zip
Add some basic functional tests.
This tests in an in-tree Apache instance using the local libmodnss.so shared library, so no pre-installation is necessary. The tests use python-nose and a hacked python-requests library. It is hacked so I can obtain the negotiated cipher and protocol as well as pass a few other things into it. Tests right now are limited to GET requests. A new user certificate for 'beta' was added to gencert to do pass/fail access control testing. The basic process of the tests are: - run setup.sh which sets up a new instance with createinstance.sh and does some variable substitution. - nosetests -v I picture multiple test "suites" of different configurations. Right now there is only one. A template file is provided for each suite. Tested only on Fedora 20 right now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 46b9b2d..164cbaa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,3 +78,24 @@ LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) \
LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in \
+ aclocal.m4 \
+ config.guess \
+ config.sub \
+ configure \
+ depcomp \
+ install-sh \
+ ltmain.sh \
+ missing \
+ ylwrap
+
+test:
+ cd test; \
+ ./setup.sh; \
+ nosetests -v; \
+ cd ..
+
+.PHONY: all test clean